Follow

Kahuna and Android M compatibility

We have announced an updated version of Kahuna SDK that is compatible with Google Play Services 8.1 and allows you to support your application on Android Marshmallow.

If your application is currently using Kahuna SDK v1, it will need to be upgraded to Kahuna SDK 2.2.3 to expand support to Android 6.0 devices. In addition to Android 6.0 support, here are the Kahuna SDK v2.2.3 features that you will be able to leverage in your application:

  • As of Android 5.1, HTTPClient library, which was previously used by Kahuna SDK v1 has been deprecated by Google and might impact your application’s interactions with Kahuna.
  • Deliver content rich messages to your users by including background images in push notifications.
  • Improved user credential functions to align with the way your app handles user’s login and logout flows.

Ready to upgrade? Download the latest SDK and refer to our step by step upgrade instructions. After a successful upgrade, we strongly recommend going through the pre-launch checklist to verify that your application’s events and user attributes are being passed accurately to Kahuna.

Frequently Asked Questions

Can I upgrade my application to Google Play Services 8.1 without upgrading Kahuna SDK?

If your application uses ProGuard and minifyEnabled is set to true, your application’s release build will fail to compile with Kahuna SDK v1. Turning off Proguard will compile your build with an pre v2.0.0 Kahuna SDK but is not recommended.

How soon should I upgrade my application?

We recommend upgrade as soon as possible and always using our latest  SDK versions to stay up to date with latest features and bug fixes. 

What version of Kahuna SDK is my app currently using?

You can find the SDK version your application is using in the Getting Started Guide. If your namespace indicates an SDK version 571 or lower, your application is using Kahuna SDK v1. If your application is using a 2.x.x you are already on the v2 version of the Kahuna SDK and simply need to confirm you are testing with the latest version.

What version of Kahuna SDK should I use for my iOS App?

We recommend using Kahuna SDK 2.2.2, which is Bitcode enabled and compatible with XCode7.

 

If you have additional questions or issues, please reach out to us at support@kahuna.com.

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments